Re: GTK+2.0 limit

Le mar 15/10/2002 à 17:33, Valdis Kletnieks vt edu a écrit :
> On Tue, 15 Oct 2002 11:59:00 +0200, Xavier Bestel <xavier bestel free fr>  said:
> > is there a way to limit the API to the GTK+2.0 API subset ? Say I want
> > to develop a GTK+2.0 compatible application, but my machine has a more
> > recent version installed.
> I'm not sure what the problem here is.  If you write it using the 2.0 API,
> then any hypothetical *new* calls in 2.1 or 2.2 etc simply won't be used by
> your program.

If I have GTK+2.2 (and devel packages, docs, etc.) I may easily forget
that a particular function is 2.2+ only. I wanted to know if something
like -DUSE_GTK20_ONLY existed.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]