Compiling pango on slackware - how I did it...


hopefully I'm not doing something wrong by posting this - but I spent 6 hours 
solving this problem and googl'ing showed some partial answers here. So maybe 
someone else might find this helpful. I once knew how to compile and link - 
but on this thing called DOS - and have no real idea of what I was doing....

I've got a Slackware 8.0 distribution. I want to compile Mplayer - using the 
GUI needs GTK - which I want to compile. No problems with atk or glib. But 
pango gave me a hard time.

I got that "parse error before `FT_Face'". I tried several things - among them 
upgrading from XFree86 4.0.2 to 4.2, upgrading to freetype 2.10 and then 
downgrading to 2.09, cheching in to the CVS tree (which lead to a all 
different set of errors...). No success. I finally stumbeled across the 
messages that tells you to "mv /usr/X11/include/freetype 
/usr/X11R6/include/freetype1". Somebody suggested to change the Makefile - 
but as I didn't knew which one, where, which value - I did the mv (BTW - if 
there is a solution in the Makefile - why are others talking about a 
Slackware problem?)

After having fixed that, I got undefined reference to `FT_Get_Next_Char' and 

I "solved" the problem by "rm /usr/X11R6/lib/" and "ln -s 
/usr/local/lib/ /usr/X11R6/lib/". I do not know 
how it came to having two freetypes - and why obvioulsly one cc did succeed 
(I guess (!!!) the freetype component which did point to /usr/local/lib) 
while the other cc failed (Xft - pointing to /usr/X11/lib).

So - again - compiling pango on Slakware for me required to rename the 
/usr/X11/include/freetype directory and to point the library to the 
/usr/local/lib - one.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]