Gtk on AIX

I have been using gtk for maybe a year on an x86 based linux machine.  I have
an app that I need to port to AIX.  I have seen some past activity in this
mailing list about gtk on AIX so I am aware that there may be some expertise 
out there.  

I have sucessfully (I think) compiled glib-1.2.8 and gtk+-1.2.8 on an 
AIX 4.3 machine using gcc.  It also sucessfully made my app but core dumps 
immediately upon invocation.  I also tried compiling some gtk examples provided
with the same result.  Here is what I get after making the notebook example.
It core dumped, and dbx on the core image is as follows:

bash$ dbx notebook
Type 'help' for help.
reading symbolic information ...
[using memory image in core]

Segmentation fault in glink.__iso_wcstok at 0xd8aa42d4 ($t1)
0xd8aa42d4 (__iso_wcstok+0x30) 800c0000        lwz   r0,0x0(r12)
(dbx) where
glink.__iso_wcstok() at 0xd8aa42d4
gtk_init_check(??, ??), line 199 in "gtkmain.c"
gtk_init(??, ??), line 423 in "gtkmain.c"
main(0x1, 0x2ff229d0) at 0x100005d4

Any ideas what I did wrong or what I need to do?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]