Undefined Symbol when compiling glib

I've encountered a problem compiling glib 1.2.6 under 

DG/UX 3.10 for M88k (yea I know, but I am stuck with it)
using GCC 2.5.8

Its an antiquated system, but if I don't get glib and gtk...well
I'll be stuck with motif and mwm (yuk!)

Anyhow, if somebody could point me the direction I need to look
in order to track down the problem I would greatly appreciate it.

The only option I used for configure was the no-threads option since
it seems this version of DG/UX does not support POSIX threads.
Make seems to work until libtool then bombs out with --

 Making all in .
        /bin/sh ./libtool --mode=link gcc  -g -O2 -Wall   -o testglib
testglib.o libglib.la 
gcc -g -O2 -Wall -o .libs/testglib testglib.o .libs/libglib.so
Undefined                       first referenced
 symbol                             in file
.L_E1366                            .libs/libglib.so
.L_E1367                            .libs/libglib.so
.L_E1368                            .libs/libglib.so
ld: .libs/testglib: fatal error: Symbol referencing errors. No output
written to .libs/testglib
*** Error code 1

*** Error code 1

*** Error code 1




Douglas Baggett
UNIX Systems Administrator
DG/UX - HP/UX - OpenBSD - Solaris

Note: Some quantum physics theories suggest that when this post is not
directly observed,it may cease to exist or will exist only in an
undetermined state

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]