Compilation/use problem

  I encounter a problem when trying to compile a gtk-using application.
Yesterday, it also cropped up after I downloaded glib/gtk+ 1.2.8 and
compiled/installed glib-1.2.8 over glib-1.2.7. I'm confident the problem has
a simple fix, but I've not yet found it.

  After running ./configure; make; make install for glib-1.2.8, I ran
/sbin/ldconfig. I then tried to do the same sequence with gtk+-1.2.8. Here,
./configure failed. Apparently, gtk-config reported glib version 1.2.8, but
autoconf found 1.2.7.

  This is the same problem I encounter when trying to build an application
that requires glib/gtk+. The last time (Sunday), ./configure failed saying
that version 1.2.7 was reported, but version 1.2.3 was found. Something has
become messed up here, and I don't know what it is.

  Here's the contents of /etc/


  (This is on a Red Hat 6.1 system.)

  Will someone here please educate me about this problem? Where are
glib/gtk+ being installed that other programs (particularly autoconf) cannot
find the correct current version? How do I fix this problem so it goes away



Dr. Richard B. Shepard, President

                       Applied Ecosystem Services, Inc. (TM)
              Making environmentally-responsible mining happen. (SM)         
            2404 SW 22nd Street | Troutdale, OR 97060-1247 | U.S.A.
 + 1 503-667-4517 (voice) | + 1 503-667-8863 (fax) |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]