Re: [gtk-list] GTK+ 1.2.3 on AIX?

Christian Starkjohann wrote:
> Hi,
> has anybody been able to compile any of the stable version 1.2.x (except
> 1.2.4) on AIX 4.0 or 4.1?
> I spent a day with it and failed at several places (after fixing lots of
> compiler problems, binaries linked to gtk+ crashed with a bus error during
> loading). This was on AIX 4.0 with IBM's compiler, somebody who tried AIX 4.1
> with gcc failed during linking glib.

 I compiled gtk+ (1.2.3 as well as 1.2.4) under IRIX and me a a colleague of
mine found gcc to be the only C compiler suitable for gtk+. The link problem
could be related to a missing libintl.a, the GNU internationalization library,
which is shipped as the gettext-distribution from GNU servers. I think that the
configure-scripts don't check, whether libintl.a is available, so installing it
seperately seems to be necessary.

Mag. Wolfgang Glas
Institut fuer hydraulische Stroemungsmaschinen
Kopernikusgasse 24                              Phone:++43/316/873/7578
A-8010 Graz                                     Fax:  ++43/316/873/7577

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]