Re: [gtk-list] difficulty compiling glib-1.2.0

Hi, Matthew

> i am having a devil of a time compiling glib-1.2.0 (and gtk+-1.2.0)
> my system: redhat 5.2
> glibc 2.07
> glib-1.15 (from rpm)
> gtk+-1.15 (from rpm)
> kernel 2.2.1
> the only error present when i execute configure  is ...
> >checking for thread implementation... none available
> >configure: warning: You do not have any known thread system on your
>                 computer. glib will not be thread safe on your computer.
> >checking necessary linker options...
> >configure: warning: the g_get_(user_name|real_name|home_dir|tmp_dir)'
>                 functions will not be MT-safe during their first call
> because
>                 there is no working 'getpwuid_r' on your system.
> configure: warning: the 'g_date_set_time' function will not be MT-safe
>                 because there is no 'localtime_r' on your system.
> checking system definitions for POLLIN POLLOUT POLLPRI POLLERR POLLHUP
> POLLNVAL... done
> ........................
> but i am using glibc from redhat 5.2 with xf86-3.3.  all that i've read
> has said that linuxthreads are for libc5 systems and with glibc it is
> already included.  is this not the case?
> is there more information i should send you?
> is there something else i need to install?
> i am using a variety of glibc programs, if i did not have it installed
> they wouldn't work, right?
> glibc 2.0.7-29  and glibc-devel (from rpm appear to be installed)
> the current glib-1.1.5 and gtk+-1.1.15 also produce a similar error when
> compiling some applications (x111amp-alpha3, but alpha2 compiled
> correctly.)

It seems, there is no /usr/include/pthread.h on your system. Can you
confirm this?

Sebastian Wilhelmi                   |            här ovanför alla molnen           |      är himmlen så förunerligt blå   |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]