[gtk-list] Installing FractalExplorer - Problems & Solutions


Installing the FractalExplorer plug-in to gimp-0.99 posed
problems because the code, as downloaded, would neither compile nor
run.  Problems included a missing header file (glibconfig.h), missing
libraries in the makefile, and a mismatch between my version of gtk
and the one the Fractal Explorer was built with. 

This document describes the necessary fixes and how I found


My system:  RedHat Linux 5.1.

While rummaging through the gimp plug-ins registry I discovered the
Fractal Chaos Explorer plug-in, and thought "Wow!, I've got to have
this!"  So, I tracked it down and downloaded it.

		      Problem #1 - glibconfig.h

Then I tried compiling it. Oops.  Problem number one surfaced:  the
file glibconfig.h didn't seem to exist.  Sure, I should have simply
run "find /usr -name glibconfig.h -print" but that would have been too
easy.  Instead, I searched DejaNews and found out that I wasn't the
only one with that problem.  A closed bug report to Debian told me
that glibconfig.h was in 
and that I simply needed to add a new flag to the compile.

So, I added 

to my CFLAGS in the makefile,despite finding a comment that said "You
shouldn't have to change anything below this line!  So, don't touch

		    Problem #2: Missing libraries

Tried the compile again, this time getting a whole slew of messages
about undefined functions.  Right.  Looked at the makefile, no X
libraries identified.  Added them to the LIBS in the makefile:

			     -lX11 -lXext

Now it compiled, but there was a new error.

		  Problem #3: gtk_tooltips_set_tips

This one was fun.  Undefined function gtk_tooltips_set_tips found in
several places.  I began by checking the on-line documentation for
gtk.  No mention of this function nor anything like it.  Tried the
documentation at http://www.gimp.org, same result.  Tried DejaNews,
searching for gtk_tooltips_set_tips, and finally got a lot of hits,
but initialy, not a lot of help.  (This problem apparently cropped up
in the ControlPanel as well as the gimp).  There were messages in a
variety of languages:  I recognized English, German, Finnish, Chinese,
and Italian.  My breakthrough came from the post by Andrea in Italian,
where he pointed out that the gtk_tooltips_set_tips had been replaced
in the later version of the library, that the new function was called


(no final "s), and that it took one more parameter, NULL.  So, I went
into the source and tweaked all the instances of the call to
gtk_tooltips_set_tips.  (One in Dialogs.h, and five more in
FractalExplorer.c).  At last, a clean compile!

			Problem #4:  Makefile

There was just one more glitch: make install didn't work because there
were spaces before the commands in the install section of the makefile.


1.  The gimp and gtk need better documentation.  At least, I haven't
    found documentation of all the functions in gtkib. The tooltips
    function is a good example of this lack.

2.  Always check the makefile!  Best if you have a collection of
    usable makefile templates with all the relevant libraries.

3.  DejaNews is a goldmine!  I'd still be floundering if I hadn't
    found my answers there.

4.  Also of great use, the websites at gnu.org, gimp.org, and gtk.org.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]