gtk_spin_buttons and focus changes



Shouldn't gtk_spin_button_get_value_as_int() always return the
_correct_ value? Currently, in 1.1.11, when I call that function to
get the value from a spinbutton of mine, the value returned isn't
correct if I call the function from a callback function that's
attached to a button of mine that has had the GTK_CAN_FOCUS flag
unset. I did that because buttons with the GTK_RELIEF_NONE style look
really stupid if they have the black keyboard focus rectangle around
them.

Browsing through the source code the spinbutton's internal value is
only updated when the widget gets a focus_out event. Now that's bad
since it doesn't get a focus_out event if a user types some text into
the entry list and then clicks one of the above buttons. Shouldn't
the get_value functions check if the text has been modified and if it
has been, update the internal value?

--
Osku Salerma - osku@iki.fi - http://www.iki.fi/osku/
Nostalgia isn't what it used to be.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]