large gdk_font_ref problem


I get this whenever I run a gtk+ app.

adam@willie:~ ./simple

Gdk-CRITICAL **: file gdkfont.c: line 115 (gdk_font_ref): assertion `font
!= NULL' failed.
Segmentation fault (core dumped)

I've just upgraded my machine to Redhat 5.2. I'd been
running 4.1 before and run into this problem after
compiling gtk+ 0.99.something and again with gtk 1.0.0.
But I didn't have time to look into it and just gave up on
getting gtk+ stuff running.

Anyway, after upgrading to 5.2 I'm now interested in getting
gnome running. I was getting the above message with all the
gtk+ apps that come with 5.2 (gtk+ 1.0 based), so grabbed all 
the gnome 0.99.3 RPMS and tried gtk+ 1.1.x. Anyway, I still 
get that message with apps that use the gtk+ 1.0 compatibility 
libs and get it with newer gtk 1.1 apps.

I got the rpms from a mirror that I know is okay because they're
all successfully running on a fresh Redhat 5.2 install at work.
My machine is pretty much untouched Redhat 5.2 (only the gnome rpms
added). I even tried to compile and run the 'simplest possible'
gtk program from the Tutorial. It compiles, but dies as above.

Anyway, I've only seen this on my personal machine. Could it
be related to my Mach64 based video card/X-server?

If anyone could suggest anything I'd really appreciate it.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]