Re: [gtk-list] testgtk strangeness on AXP (Alpha) architecture

On Wed, Feb 03, 1999 at 10:42:08PM -0600, Andrew P. Lentvorski wrote:
> If I attempt to run gdb on testgtk I get:
> "/home/compile/gtk+-1.1.14/gtk/testgtk": not in executable format: File format n
> ot recognized
> Yet, if I run testgtk it pops up a window and the button box and buttons
> selections work, but selecting check buttons gives:
> Gdk-ERROR **: BadAccess (attempt to access private resource denied)
>   serial 5878 error_code 10 request_code 129 minor_code 3

  Hi Andy,

    I've also had a lot of wierd errors with gtk+ on my Alpha. The version
that shipped with RedHat v5.1 works fine but any of the tar.gz images that
I download from crash with BadAccess errors. After looking at
the RedHat Source RPMs. I found that RedHat has patched gtk+ by disabling
Xwindows shared memory. This has fixed the BadAccess errors that I ran into.
Although YMMV.

Attached to this is the RedHat patch distributed with Gtk+1.0.1 it worked
for me with gtk+1.0.6. It's really small and it's a one line
change so try applying it to gtk+ 1.1.14. If not you should be patch the 
code by hand. It just sets a variable to FALSE.

Rob.                          |            |  | POWERED by LINUX!!!!
--- gtk+-1.0.1/gdk/gdkglobals.c.msf     Tue May 15 12:35:40 2018
+++ gtk+-1.0.1/gdk/gdkglobals.c Tue May 15 12:36:01 2018
@@ -22,7 +22,7 @@
 #include "gdkprivate.h"
 guint             gdk_debug_flags = 0;
-gint              gdk_use_xshm = TRUE;
+gint              gdk_use_xshm = FALSE;
 gchar            *gdk_display_name = NULL;
 Display          *gdk_display = NULL;
 gint              gdk_screen;

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]