Re: [gtk-list] Re: Compiling GTK

I've tried updating what I could find currently I have the following
rpms installed:


I was able to update libc from the 5.3 version that I had but I have not
found any other more recent libraries. I was wondering if there are
conflicts between the libraries. I tried to install the libc-devel
rpm and it wouldn't let me because of conflicts. Is it possible that
I may not correctly specify the library paths?


On 13 May 1998, Owen Taylor wrote:

> That last bit is fairly revealing. What is happening is that
> when GTK is configured, it tries a similar compilation and
> got a similar error, so it decided you didn't have any X libraries. 
> Instead of aborting the configuration (as it should), it just
> continued on without them, until it tried to link testgtk.
> I think what your problem is is that the X libraries you have
> are linked against a different C library than the C library
> on your machine. (It is an X-library - C-library incompatibility
> in any case). So you might want to try updating one or
> both of those and see if that helps.
> Regards,
>                                         Owen

Charles Anthony Peterson
Graduate Student of Physics
at the University of Arizona
Office:(520)621-9558 Home:(520)881-6605

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]