Re: [gtk-list] Re: gtk+ on AIX

> > Sorry if this is old hat, I just figured it might be useful to someone
> > unfortunate enough to be stuck working on an AIX box who's not real
> > familiar with gtk+.
> Hmm. That shouldn't be at all necessary. 

Whoops (damn, that's twice today), you're right, it's not.  I don't know
exactly why it worked when I tried it again, we have a few different
boxes, and they're all configured differently.  Anyway, I don't know if
this matters, but I had some environment variables set for a different
project.  First was SYSTEM, and I also had CC defined to xlC -+ (admittedly
stupid, but it's fixed now).  Anyway, when I fixed up/removed those vars,
things started working fine.

I don't know, I just wish I could retract that first email, nothing's worse
than trying to be helpful and giving out bad info.  Oh well.

> The shared extension is supposed to work with AIX now. There was a
> patch specifically applied to for that purpose.
> Could you send me the main config.log too?

When I redid everything with the shared extension on, and xim off (cause
it's R5), things seem to be fine.

One thing that *does* still bug though is that, even though everything
builds OK, it fails on make install, because AIX's installbsd has a default
owner of root, and so I had to go explicitly say in all the makefiles,
installbsd -c -o bstempel -g fcs ... instead of just installbsd -c.  Is there
any way around this?

Anyway, thanks Owen for the wake up call.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]