Re: [gtk-list] Problem compiling GTK/Perl 0.2.04 on solaris

On Sun, 30 Aug 1998, Mohamed Hendawi wrote:

> I cannot compile GTK/Perl 0.2.04 on Solaris 2.51 with perl 5.004_04.  I get
> the following
> error:
> ld: fatal: too many symbols require "small" PIC references:
>     have 4543, maximum 2048 -- recompile some modules -K PIC.
> Any idea what this could mean?  I have tried this with all permutations of
> GTK/Perl 0.2.04 and 0.3 and GTK 1.0.5 and 1.1.1.
> One thing I find suspicious is the fact that I am using gcc as the compiler
> and /usr/ccs/bin/ld to link.  That seems fishy.  Shouldn't gcc be using it's
> own linker?  It's possible that my system has been configured incorrectly.
> One additional note:  I tried hacking the CCFLAGS in the Makefile to include
> "-fpic".  I still get the same problem though.

If I remember right, you might have better luck if you use -fPIC, instead
of -fpic. But you might need to make this change in Perl, as well.
Unfortunately, Gtk/Perl has so many exported symbols that it is
overflowing the (somewhat) limited -fpic symbol space. 

Kenneth Albanowski (, CIS: 70705,126)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]