Re: [gtk-list] Bad Accesws again

Linus Gasser <> writes:

> Hello,
> I had this problem already once:
> ** ERROR **: BadAccess (attempt to access private resource denied)
>   serial 35384 error_code 10 request_code 129 minor_code 3
> I get it with the testgtk-programm when I click on shapes (and several others).
> Someone told me to get a non-Redhat-kernel and it would be OK. It was, but just
> for 1 reboot! 

> The next time I did a reboot I got the same error again. 

Hmmm, are you sure that the second time you booted you used the
new kernel, not your original one? 

[ I don't think Redhat vs.  non-Redhat kernels would make a
difference, but rebooting again certainly shouldn't make a
difference... ]

> Also Xaos and MTV give me the same error. As I understood up to now
> it has to do with virtual-memory-space in X-Windows.

This is a (non-GTK+-specific) problem with the X shared memory
extension. If you configure GTK+ with the --disable-shm flag,
this should solve the problem for GTK+. (The GTK+ shipped with
RH 5.1 for the Alpha platform is configured in this manner.)

I have a vague memory that this problem may have been fixed
in the 2.1 kernels, but don't trust me on that one.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]