Re: [gtk-list] Large change to gtk-- signal system!



Tero Pulkkinen wrote:

> The change is to make it explicit which type of connect() function we're
> using. Thus the previous examples will become:
>   connect_to_function(signal, &function);
>   connect_to_signal(signal, functionobject);
>   connect_to_method(signal, obj, &fooclass::method);
>
> This change will hopefully make it easier for people and for the compiler
> to handle these different types of connect() functions.

This is fine to me. Actually I didn't know there was the possibility of an
function object. Because there was this web/knot/bunch/heap of connect
declarations, which I never scanned if not _forced_ to.

I prefer connect_to_functionobject, since connect a signal to a signal ... are
these really the same species? This would confuse people a lot if there is only
the slightest difference.

> For practical reasons I dont want to leave the old connect() calls inside
> gtk--, as then people will use them still and we'll have more code in our
> hands that must eventually be changed.

The old code was ambiguous and difficult to read. Kill it!

Perhaps provide a have_to_explicitely_state_so define (-DOLD_CONNECT) which
provides the old syntax for the poor end-user trying to compile old stuff. You
can warn like hell, but there might be old stuff around for a while.

Christof





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]