Re: [gtk-list] Large change to gtk-- signal system!



Tero Pulkkinen wrote:
.
.
.
> The sollution:
> The change is to make it explicit which type of connect() function we're
> using. Thus the previous examples will become:
>   connect_to_function(signal, &function);
>   connect_to_signal(signal, functionobject);
>   connect_to_method(signal, obj, &fooclass::method);
> 
> This change will hopefully make it easier for people and for the compiler
> to handle these different types of connect() functions.
> 
> For practical reasons I dont want to leave the old connect() calls inside
> gtk--, as then people will use them still and we'll have more code in our
> hands that must eventually be changed.
> 
> So, I'm asking your opinions, if this change should be made and how
> much problems it'll cause to the users of gtk--. Naming issue is not
> absolutely clear yet either, especially with connect_to_signal() vs
> connect_to_functionobject().
> 
> Any opinions are welcome.
> 
> --
> -- Tero Pulkkinen -- terop@modeemi.cs.tut.fi --

	Hello.
	As other people say, go ahead and do these changes. Concerning to
conect_to_signal vs conect_to_functionobject, I think the first is
easier to new gtk-- programers (when I began using gtk-- I didnīt know
what is a function object). For more experts programers there is no
problem to know that when it say signal you can put any function object.
They are more expert :).

	
-- 
+--------------------------+---------------------------+
|David Abilleira Freijeiro | Pontevedra, Espaņa        |
+--------------------------+---------------------------+
|http://members.xoom.com/odaf   (mailto:odaf@nexo.es)  |
|    (UNED, Mis Programas, Linux, Programación, etc.)  |
|WAINU: http://www.geocities.com/Athens/Forum/5889/    |
+------------------------------------------------------+



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]