Re: Pango and Freetype incompatibility

On 20 Feb 2003 17:08:09 -0500
Owen Taylor <otaylor redhat com> wrote:

> If you are using Xft2, you must use pango-1.2.x. Which is better,
> anyways.

Good advice.  I downloaded pango-1.2.1.  When I try to configure it I get this:

/src/pango-1.2.1# ./configure
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking for GLIB - version >= 2.1.3... 
*** 'pkg-config --modversion glib-2.0' returned 2.2.1, but GLIB (2.0.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from

I've been looking in the configure script trying to understand where the configuration test is looking for the major/minor/micro version strings.  I have glib.h for glib 1.2 and 2.0 on my system as shown:
~# locate glib.h

Where is the configuration test getting the 2.0.4 version info from?

Thanks for helping,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]