Re: Reinstate support for OS X versions older than 10.9

On Sep 22, 2015, at 3:47 PM, Ryan Schmidt <gtk ryandesign com> wrote:

Hello, I'm the maintainer of glib2 in the MacPorts package management system.

glib 2.46.0 was recently released, and attempting to configure it produces this error:

checking OSX version >= 10.9.0... no
configure: error: OSX version is too old!

glib 2.45.2 and earlier worked fine on older versions of OS X, but 2.45.3 and later claim to require 10.9.

My understanding is that the implementation of GNotification support for OS X [1] necessitated this 
increase in minimum OS version. But this huge jump in minimum OS version makes glib unusable on hundreds of 
older Mac models [2] that cannot be upgraded to OS X 10.9 that were previously able to use glib. I urge you 
to reconsider this action and reinstate support for older versions of OS X by making the GNotification 
support optional. Clearly, since GNotification support was just added, no existing apps that used glib and 
that already worked on OS X can have required this functionality.

I originally expressed this concern in the issue tracker [1] but was advised to bring it up on the mailing 
list for discussion instead.

In response to my comment in that ticket, doubt was expressed as to the usability of glib on older systems, 
even prior to this. I can at least tell you that Graphviz, which uses glib, worked fine all the way back to 
OS X 10.4, which is the earliest system I tested. I'm happy to run your test suite on older systems and 
report bugs for any problems found.

I’m a bit conflicted about this. Yes, 10.9 is a bit new for a cutoff, but on the other hand upgrades to 10.10 
are free and run on any machine that can run 10.7 so there’s not much of an excuse and considerable security 
risk for anyone with such a machine not to be running the latest release. That still leaves all of those 
folks with PPC and 32-bit Intel Macs who are stuck at 10.5 and 10.6 respectively. Yeah, it’s nice to support 
them with Gnome applications — I’m among those who do, providing 32-bit PPC and Intel bundles for GnuCash and 
Gramps. OTOH it’s not really reasonable for them to expect to be supported forever, and I bet they can’t get 
many new native applications for their obsolete hardware either.

All of which said, it does seem unreasonable that a very minor feature implementation in a dark corner of GIO 
should block building all of GLib. On the bug Emmanuelle asks whether GLib runs on those older OSes and how 
much of the API is used. The answer is yes, absolutely, and all of GLib and GObject are used pretty 
extensively by many Gnome apps ported to Mac and Windows. The apps I maintain don’t use a lot of the newer 
GIO features like notifications or even the GApplication stuff intended to make Gnome apps more portable 
simply because no-one has made the effort to redesign the applications to use them. (It’s in my to-do list 
for Gramps, but it’s *way down* that list.) I can’t speak for other projects, but I suspect that the same is 
true for many.

There’s always the option of sticking with the last releases of GLib and Gtk+ if you want to build/run on 
older machines.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]