GTK+ scene graph


Some questions about the GTK+ scene graph ([1]).

Why not reusing the height-for-width and width-for-height sizing
requisition type? Will it Just Work with the constraint-based layouts?

For functions like gsk_layer_set_z_position() having 'z' in the name,
have you considered naming them with "depth" or another more meaningful
name than a single letter? I know everybody use x/y/z, but personally
when I read some "math" code with lots of single-letter variables, I
find it more complicated to understand. Maybe the API should be free of
such single-letter math stuff, or if a convention is followed, document
it clearly somewhere (but there should not be too many conventions for
single letters, since it's harder to memorize).

Best regards,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]