Re: gvfs status report

On Thu, February 15, 2007 10:54, Alexander Larsson wrote:

> One thing that I'm especially unsatisfied
> with is the naming. There is just way too many "vfs", "daemon" and
> "dbus" all over the place.

Speaking of which:

> GInputStream
>   GInputStreamSocket
>   GFileInputStream
> GOutputStream
>   GFileOutputStream
>   GOutputStreamSocket

You probably thought about it already, but why not GSocket{Input|Output)Stream?

In general I think naming works good if the interface is named with the
abstract concept, and the implementation is named:

For example:
  interface:       GInputStream:
  implementations : GFileInputStream, GSocketInputStream, GByteArrayInputStream, etc.

Consistency help.

That being said, I think a more "practical" naming would be:


   GInputStreamFile, GInputStreamSocket, etc.

that would allow easier completion in IDEs such as Eclipse.

But at the end of the day I would go with Java/.NET naming,
I don't think it's worth going against the grain of what people expect.

Dimi Paun <dimi lattica com>
Lattica, Inc.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]