Building with Quartz support on MacOs X 10.4.5

Hello people,

I'm a mac user type and I'm trying to build Gtk on Mac because I hope I can contribute some code to help integrate it on Mac.

Probably the things I'm gonna ask are basic to you, but that's that Unix stuff I'm not familiar with. Please understand me.

Now, down to business: I installed Gtk+ with native quartz support with Fink. It worked.

Then, I tried to build it myself following the instructions at

That doesn't work.

I installed the indicated versions of automake and autoconf and libtool and gettext and pkg-config.

They all build and installed ok.

Now, if I type "which automake" and "which autoconf" the reply is "/usr/bin/automake" and "/usr/bin/automake"

The ones I installed are in "/usr/local/bin"

Do the scripts attempt to find the right ones ? Or do they trust the enviroinment ?

The first problem I have is when I try to compile atk. Here it is:

ibook-di-ciccio-cauro:~/Desktop/Gtk/sorgenti/Atk/atk adri$ ./ --prefix=/usr/local/ --disable-gtk-doc
Symlinking file mkinstalldirs
Symlinking file po/

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
from the /usr/local/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from installing `./install-sh' installing `./missing' installing `./INSTALL'

Then, it continues until the end. The installation also seems to perform correctly.

What does that mean ? What is my autoconf macro directory ?

Since it found those files in /usr/local/share/aclocal/ why doesn't it copy them itsself ?

Even the config.guess and config.sub files are in /usr/local/share/aclocal

What's going wrong ?

The second problem comes when I try to compile Pango. Here it is:

ibook-di-ciccio-cauro:~/Desktop/Gtk/sorgenti/pango adri$ ./ --prefix=/usr/local/ --disable-gtk-doc --without-x installing `./install-sh' installing `./mkinstalldirs' installing `./missing' installing `./INSTALL'
examples/ installing `./depcomp'
modules/arabic/ installing `./compile'
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking build system type... powerpc-apple-darwin8.5.0
checking host system type... powerpc-apple-darwin8.5.0
checking for native Win32... no
. [blah]
. [blah]
. [blah]
checking for perl... perl
checking for X... disabled
configure: WARNING: X development libraries not found
checking for pkg-config... /usr/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for FONTCONFIG... configure: WARNING: No fontconfig found, skipping tests for FreeType and Xft
checking Carbon/Carbon.h usability... yes
checking Carbon/Carbon.h presence... yes
checking for Carbon/Carbon.h... yes
checking for CAIRO... configure: error: *** Didn't find any of FreeType, X11, ATSUI or Win32.
*** Must have at least one backend to build Pango.
ibook-di-ciccio-cauro:~/Desktop/Gtk/sorgenti/pango adri$ ./ --help
`configure' configures pango 1.11.6 to adapt to many kinds of systems.

It didn't find ATSUI ? Why ?

I'm on Mac !! ATSUI must be there ! Maybe the CPPFLAGS=-I/usr/local/include and LDFLAGS=-L/usr/local/lib env vars are disturbing ?

Thanks so much for any help


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]