Re: Some introspection on GtkContainer children.

On Wed, 2005-09-14 at 23:27 -0400, Tristan Van Berkom wrote:

> On a more practicle note; I was thinking that internal children of
> composite widgets should be more introspectable; for the purpose
> of GUI builders and loaders, if every child widget implicitly created
> by its parent at least had a name, we could avoid alot of special
> case code and maintanence.

Composite children can be marked when created by the container calling

They can also be named with gtk_widget_set_composite_name(), though this
hasn't been used much in GTK+ itself.

Ideally a GUI builder shouldn't have to touch composite children - the
properties of the widget should be enough to configure it completely.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]