[Fwd: Re: problem building glib on linux]

Matthias Clasen said the following on 07/12/2005 10:12 AM:

On Tue, 2005-07-12 at 09:59 -0700, Steve Kelem wrote:
Steve Kelem said the following on 07/11/2005 10:30 PM:

I'm trying to compile the latest cvs version of glib on SuSE linux 9.3
with pango 1.9.0
with cairo & libpixman from the latest cvs.
1. There's no "configure".
2. If I run autogen.sh, it complains:

You must have automake 1.7.x installed to compile GLib.
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/

% automake --version
automake (GNU automake) 1.9.5
Written by Tom Tromey <tromey redhat com>.

Copyright 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

I edited autogen.sh to use automake-1.9, and get the following messages:

Why do you complain then ? It told you it needs automake 1.7.

Really? It requires an old version of automake? I don't see that in INSTALL: Requirements. Grumble grumble....I'll hunt it down. Which one? 1.7, 1.7.1, 1.7.2, 1.7.3, ... 1.7.9?
I wonder what /else/ I will need...

I'm not so much complaining, but pointing out for the developers that it isn't seamless for anyone not working in the thick of things. I really want to get my real work done. I really want to get gnucash working. I really want to get away from Micros**t, which I had viewed as a pain in the ***. Okay, I am complaining...but I hope in a way that will get some clarifications to make it easier for me and others
to be able to use this software.  I'm trying to help improve the product
from and end-user's view.


Okay, I installed automake-1.7-9, and it still doesn't work.  I get the
same result.  What should I try next?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]