possible TreeView DND code simplification



Good morning,

While browsing the dnd code, I realized that gtktreednd.c:257

  struct_size = sizeof (TreeRowData) + len + 1 -
    (sizeof (TreeRowData) - G_STRUCT_OFFSET (TreeRowData, path));

might be far easier to read as

  struct_size = G_STRUCT_OFFSET (TreeRowData, path) + len + 1;

(mathematical equivalent of the above)?


Should I send a patch?

Yours
   Christof




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]