Re: gtktoolbar - packed with invisible widgets ...



Michael Meeks <michael ximian com> writes:

> 	How about the attached ? may I commit ?


>  {
>    if (strcmp (pspec->name, "is_important"))
>      gtk_tool_button_construct_contents (GTK_TOOL_ITEM (object));
> +
> +  parent_class->notify (object, pspec);
>  }

I think it should say 

        if (parent_class->notify) 
                parent_class->notify (object, pspec);

for clarity and for the benefit of future cut-and-pasters.

The strcmp() is obviously wrong (existing bug). It should say

        if (strcmp (pspec->name, "is-important") == 0)
                ...;

The hyphen vs. underscore thing is the only reason it worked previously.

> +  if (tool_item->priv->menu_item && strcmp (pspec->name, "sensitive"))
> +    gtk_widget_set_sensitive (tool_item->priv->menu_item,
> +			      GTK_WIDGET_SENSITIVE (tool_item));

This has the same strcmp() problem

Other than those things, it looks fine to commit.

Thanks for finding these bugs.

Søren



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]