Ok, to start off... this may not be the correct list for this question. But i'm sending it here for a couple reasons. People in #gtk+ on NEVER answer my question, there is 0 traffic on the mailing list that i was told to sign up for on the pango homepage, and I figure you guys are a bunch of smart people who know what's going on. So anyway.... here's my problem. I'm trying to get pango running so that I can get gtk+-2.0.2 installed... but i'm having MASS TROUBLE with it. I dont know how much of this you can help me with, but I'm having two issues. First, and this is only actually pretty recently, the pango configure script won't detect glib. I have two different versions of glib installed, like 1.2.0 and then the newer 2.0.1. Alright this worked fine at first, I don't know what happened but now the script won't detect the new one at least, i'm not sure if it's detecting the old one. Here is the error message:

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the *** exact error that occured. This usually means GLIB was incorrectly installed *** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the pkg-config script: /usr/local/bin/pkg-config
configure: error:
*** Glib 2.0.0 or better is required. The latest version of
*** Glib is always available from

Output from ldconfig -v | grep glib gives this: -> ->

And before I was having trouble with this glib nonsense, I was having trouble with freetype! Something with ftxopen.c during make, I don't have the error messages handy because I can't even get the stupid thing configured now.

Seriously, if you guys could help me that would be awesome. I kno this isn't the place for this question, but i've pretty much tried everywhere else, and you guys seem nice.

Thank you!!!

--Kolbe Kegel

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]