pango-rc1-1.0.0 fails configure under Solaris

I tried compiling rc1 under Solaris with the following system params:

  prompt> uname -a
  SunOS gelerak 5.8 Generic_110517-03 sun4u sparc SUNW,Ultra-5_10
  prompt> cc -V
  cc: Sun WorkShop 6 update 2 C 5.3 2001/05/15
The following were the result:

1. glib and atk configured and compiled without any problem.

2. pango failed configure with the following error:

   checking Whether to write dependencies into .pc files... ./configure: test: unknown operator ==

The following patch fixes it:

    ---    Wed Mar  6 08:29:14 2002
    +++        Wed Mar  6 08:29:27 2002
    @@ -549,7 +549,7 @@
     case $enable_explicit_deps in
	 deplib_check_method=`(./libtool --config; echo eval echo \\$deplib_check_method) | sh`
    -    if test "X$deplib_check_method" == Xnone || test "x$enable_static" = xyes ; then
    +    if test "X$deplib_check_method" = Xnone || test "x$enable_static" = xyes ; then

3. Compilation of pango failed mysteriously with the following error:

    gmake[3]: Entering directory `/data/junk/gelerak/dov/src/gtk-2/pango-rc1-1.0.0/pango'
    cc -DHAVE_CONFIG_H -I. -I. -I.. -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/data/alg/local/etc\" -DLIBDIR=\"/data/alg/local/lib\" -DG_DISABLE_DEPRECATED -I/usr/openwin/include  -I..    -g    -I/data/alg/local/include/glib-2.0 -I/data/alg/local/lib/glib-2.0/include   -c querymodules.c /opt/SUNWspro/bin//../WS6U2/bin/acomp: fatal: relocation error: file /opt/SUNWspro/bin//../WS6U2/bin/acomp: symbol dbg_begin: referenced symbol not found
    cc: Fatal error in /opt/SUNWspro/bin//../WS6U2/bin/acomp : Killed
  I don't understand this as the sources contain no reference to
  dbg_begin. Possibly it is a SunForte compiler bug.

4. Recompiling with gcc worked.
5. Got same error when compiling gtk+ . Compilation worked with gcc.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]