Re: gdk_input_add() again



"satyajit  kanungo" <satyajit kanungo wipro com> writes:

>    Hi All,
>  
>    I was trying to remove all deprecated gdk and glib calls from the 
>    gtk library. The function gtk_input_add_full() in gtkmain.c file uses the 
>    deprecated gdk_input_add_full call and  there is no exact replacement for this .
>    From one of the discussion I came to know  I can replace the gdk_input_add functionality 
>    with g_io_channel_unix_new(), g_io_channel_add_watch() and  g_io_channel_unref().
>    
>    Is it advisable to the same kind of change for gtk library . 
> 
>    Because the parameters passed in gtk_input_add_full() are of different type,
>    and I can not change the type of parameters passed to  gtk_input_add_full() to 
>    implement the method  using g_io_chnnel functions. 

I don't think it's a good idea to duplicate the code from gdk_input_add_full()
just to avoid using a deprecated function.

The gtk_input_* gtk_idle_* gtk_timeout_* functions all should have been
deprecated, most likely, but it's too late to deprecate these commonly
used functions for 2.0.0 at this point. (Filed the issue as #71596 so
we don't forget about it in the future.)

Please note my comment on #52790 -- I think we need to hold off on all 
"remove deprecated functions" patches until after 2.0.0.

Regards,
                                        Owen
 






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]