problems with glib 2.0.1

Hello list,

I was on the way to install gtk+-2.0, but it seems I have problems.

./configure && make && make install of glib went smooth, but make check
(which I didn't execute at first) throws this :
[colin chloe ~/download/gtk2/glib-2.0.1]$ make check 2>&1 | grep FAIL
FAIL: gio-test
FAIL: iochannel-test
FAIL: mainloop-test
FAIL: uri-test

(ask if you want the full output)

I tried the "make check" because I got problems installing pango (for
pango too, ./configure && make was ok) : for pango the "make install"
failed due to pango-querymodules segfaulting :
[colin chloe ~/download/gtk2/pango-1.0.1]$ gdb ./pango/pango-querymodules 
This GDB was configured as "ppc-redhat-linux"...
(gdb) run
Starting program:
# Pango Modules file
# Automatically generated file, do not edit
# ModulesPath = /usr/local/lib/pango/1.0.0/modules

Program received signal SIGSEGV, Segmentation fault.
0xfc0e5a8 in strlen () at eval.c:88
88	eval.c: No such file or directory.
(gdb) bt
#0  0xfc0e5a8 in strlen () at eval.c:88
#1  0xfbf7b2c in fputs () at eval.c:88
#2  0xfe38a5c in g_print () at eval.c:88
#3  0x10000d50 in query_module (dir=0x10001148 "", 
    at querymodules.c:92
#4  0x10000fb8 in main (argc=268513419, argv=0x10011e58) at
#querymodules.c:156 5  0xfbad060 in __libc_start_main () at eval.c:88

I tried adding a "g_print("test");" in querymodules.c:92 and it segfaults
too. Is this a bug in glib or a specific issue with my install ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]