RFC: renaming libgobject

We've been discussing renaming libgobject to something else
for a while. For a couple of reasons:

 - It may be confusing to have both the library and the object
   type named GObject.

 - We've discussed moving the mainloop into gobject so it
   can use GClosure for callback, libgobject might be a 
   confusing name then.

 - People have been including gobject/gobject.h instead of

The initial name I suggested was "gruntime", but the reading
of that as grunt-ime makes it an unattractive name.

The current best candidate is "libgrt", as being unmemorable
but unobjectionable.

Other suggestions came up:

 libgoo  [ already used a couple of times ]
 liboo [ -loo ]
And it got worse from there. If you have better ideas, or
good reasons to keep the library libgobject, let us know.
Otherwise, I'll make the change in a few days. 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]