Re: none



Havoc Pennington <hp redhat com> writes:

> It has exactly one feature not found in GObject, which is the
> "destroy" signal. Our claim is that "destroy" is only useful for GUI
> objects, so "destroy" should really be in GtkWidget. So GtkObject is
> just legacy cruft.

I agree with Maciej in that having a base class with a ::destroy()
signal is useful.  It is used in widgets, canvas items, bonobo
objects, and likely other stuff.

So there seems to be a need for something general that supports
widget-like destruction semantics.  What if we create a
GDisconnectableObject or something with a less ugly name and put the
signal there?  GtkWidget would then derive from it, as would
GnomeCanvasItem and Bonobo thingies and friends.

> You should never type a function that begins gtk_object_ anymore and
> you should never use the GTK_OBJECT() cast, because in all cases you
> should be using GObject or GtkWidget. The only legit way to use
> GtkObject is too connect to "destroy".

If we are doing the Big Rename anyways, GtkObject should *really* go
away.  This will make it easier to ensure that code has been ported
properly to GObject.

  Federico




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]