help please

I've posted this to the gtk-list more than once.  I'm having trouble, and
have tried everything that I can think of.

I'm using slackware 3.6 and I'm having trouble with a build gtk+-1.2.1.
the make continues to error out, complaining about dgettext.  I've tried
configuring with './configure --with-included-gettext', but that doesn't
make a difference.

Below is the error that I get.

Please help if you can.  I may be doing something idiotic, but I can't
figure it out.  

one hint I have, is during the build, getting:

*** Warning: This library needs some functionality provided by -lintl.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.

I don't have the libintl.o.  I got gettext source, and built it, hoping
that I would get the dymamic version built.  But, I couldn't figure out
how to get it to build the dynamically linked libintl.o

Please help, the error is below.


gcc -g -O2 -Wall -o .libs/testgtk testgtk.o .libs/
-L/usr/local/lib -lgmodule -lglib -ldl -L/usr/X11/lib -lXext -lX11 -lm
-lintl ../gdk/.libs/ -lgmodule -lglib -ldl -lXext -lX11 -lm
-lintl -L/usr/X11/lib -lXext -lX11 -L/usr/local/lib -rdynamic -lgmodule
-lglib -ldl -lm -lintl -Wl,--rpath -Wl,/usr/local/lib
.libs/ undefined reference to `dgettext'
make[2]: *** [testgtk] Error 1
make[2]: Leaving directory `/usr/src/gtk+-1.2.1/gtk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gtk+-1.2.1'
make: *** [all-recursive-am] Error 2

                In a world without walls, who needs windows?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]