Re: Plans for 1.3/1.4

Karl Nelson <> writes:

> This isn't a proposal so much as a wish list...
> I would like to see a consistently named set of functions 
> that set the minumum, maximum, requested, and allocated size
> of a widget.  Something like set_usize, set_msize, set_rsize, and
> set_asize.  Although longer more explicit names like set_min_size(),
> set_max_size(), set_req_size(), and set_alloc_size().
> It seems to be a common problem that user must set the minumum size
> then reset it later if they want to shrink the window or such.
> This would solve that problem.  As the functionality is largely there
> this should be a major change.

Actually, the functionality is not there at all. GTK+ does
not have separate conceptions of minimum, maximum and default
sizes for each widget, and adding that would be a huge
amount of work. (because every container needs to propagate
all those values upwards in a meaningful way - and the correct
way to do that is often not easy to figure up)
Although such functionality would be useful, it isn't clear
that it is worth the extra complexity. Note that most 
of the functionality you would get can be achieved, if
a little less conveniently with:



> Also much of the gdk code uses the name GdkWindow when it means
> GdkDrawable.  Although this is little more than a typedef, 
> the lack of distiction is a bit confusing.
> This should be cleared up during the merge of the two codes.

If a patch implementing this was made up, I don't see
any problem in applying it.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]