Re: visible vs. is_visible

"Sergio A. Kessler" <> writes:

> Some widgets implements a method "visible" and others implement 
> "is_visible" when they want to inform if the widget _is_ visible.
> I think the meanings of the last is much more clear.
> (or must be set/get visible ?)

We went on a crusade between GTK+-1.1 and GTK+-1.2 to 
make everything that was a getter or a setter be
get_foo() and set_foo().

We didn't do the same for boolean-valued query functions.
Perhaps that will happen at some point in the future...
there should probably be a policy one way or the 
other for future naming in any case.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]