GLib 2.19.8 released

GLib 2.19.8 is now available for download at:

glib-2.19.8.tar.bz2 md5sum: b2898de261b212dcc1244b624ed756a5
glib-2.19.8.tar.gz  md5sum: 4a087c57405b8135d610d94fe43e76da

This is the a development release leading up to GLib 2.20.


 * This is unstable development release. While it has had
  a bit of testing, there are certainly plenty of bugs
  remaining to be found. This release should not be used
  in production.

 * Installing this version will overwrite your existing
  copy of GLib 2.18. If you have problems, you'll need
  to reinstall GLib 2.18.

 * GLib 2.20 will be source and binary compatible with
  the GLib 2.18 series; the new API additions in GLib 2.19 
  are finalized at this point.

 * Bugs should be reported to

About GLib

GLib is the low-level core library that forms the basis for projects
such as GTK+ and GNOME. It provides data structure handling for C,
portability wrappers, and interfaces for such runtime functionality as
an event loop, threads, dynamic loading, and an object system.

More information about GLib is available at:

An installation guide for the GTK+ libraries, including GLib, can
be found at:

Overview of Changes from GLib 2.19.7 to GLib 2.19.8

* GIO: Fix missing exports of new API

* Fix strict aliasing warnings and violations to make Glib work
  with gcc 4.4

Thanks to Jakub Jelinek for the strict aliasing fixes.

February 17, 2009
Matthias Clasen

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]