Re: how can i access usb memory stick as a non-root

harshavardhanreddy mandeepala wrote:

i am using linux fedora core 3.
i want to access usb memorystick as a non-root user.
i can mount and umount as a root,but when i want to do it as a "guest"(non-root)
it is giving as a  "only root can do it"
i have changed the ownership of  /dev directory  to "guest" but still
it is giving same error.
even i added these fallowing lines to my /etc/fstab

/dev/sda1 /mnt/usbstick vfat noauto,user,umask=000 0 0
still it is giving same message as a  only root can do it.
If u know the solution plz mail me to                hvreddy1110 gmail com
thanks in advance.

I had the same problem and FC3 wasn't at fault. It was the linux kernal that came with FC3. There was a USB bug in kernal vesions prior to 2.6.11. If you have root access and update your linux kernal the problem will automagically go away. I downloaded the following four files, the 2.6.11 kernal and its three dependancies from and USB ports worked ok.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]