Re: Compile Line for GnomeVFS Programs. <-- thanks

Thank you, Antonio:

Thanks for pointing that resource out to me!  I did a search for gnome.h
on the "unstable" version and up popped:


So I did the compile line like this:

 gcc `pkg-config --cflags --libs libgnomeui-2.0 gnome-vfs-2.0`
gnome_vfs.c -o test

... and it compiled just fine:-)

I just wish that these example programs and tutorials would have compile
line examples to go with the code.

Thanks for helping!


On Wed, 2005-02-09 at 16:26 -0400, Antonio Gomes wrote:
Hi ...

Go to the site , section
"Search the contents of packages", mark the "packages that contain
files or directories whose names contain the keyword" option, and then
type in the entry 'gnome.h' (or the others file mentioned above -
gfileutils.h - gnome-util.h). It will show you what debian package
(.deb) to download and install using synaptic or apt-get ...

Best Regards 

On Tue, 08 Feb 2005 19:34:04 -0500, Tony Freeman
<tony freeman insightbb com> wrote:
Trying to compile the program located at:

Here's the compile line I'm using now and the output:

gcc `pkg-config --cflags --libs gnome gnome-vfs-2.0` gnome_vfs.c -o test

In file included from /usr/include/gnome-1.0/libgnome/libgnome.h:39,
                 from /usr/include/gnome-1.0/gnome.h:16,
                 from gnome_vfs.c:2:
/usr/include/gnome-1.0/libgnome/gnome-util.h:29: error: conflicting
types for `G_FILE_TEST_EXISTS'
/usr/include/glib-2.0/glib/gfileutils.h:70: error: previous declaration
/usr/include/gnome-1.0/libgnome/gnome-util.h:35: error: conflicting
types for `g_file_test'
/usr/include/glib-2.0/glib/gfileutils.h:84: error: previous declaration
of `g_file_test'

Here's another guess at the compile line with results:
gcc `pkg-config --cflags --libs libgnome-2.0 gnome-vfs-2.0` gnome_vfs.c
-o test
gnome_vfs.c:2:19: gnome.h: No such file or directory

It seems to me that I need to have the "gnome-2.0" include files ... but
I don't know where to get them.  I have Debian.  Any idea what the
package name would be that I need to install?  I've searched all over
using Synaptic for gnome development packages and I've installed a
bunch ... but nothing seems to help.


On Mon, 2005-02-07 at 22:06 -0500, Allin Cottrell wrote:
On Mon, 7 Feb 2005, Tony Freeman wrote:

Every time I try to compile a program that has a "#include <gnome.h>" I
run into problems.  For example:  I have just finished typing in the
sample program located at:

Now I want to compile.  I finally got the program to compile with this

gcc `pkg-config --cflags --libs gnome libgnomevfs` gnome-vfs.c -o test


pkg-config --cflags --libs gnome gnome-vfs-2.0

If this doesn't work, then you don't have the right files installed.

Allin Cottrell

gtk-app-devel-list mailing list
gtk-app-devel-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]