Re: gtk+ link error

Michael L Torrie wrote:
On Tue, 2003-11-04 at 04:09, Russell Shaw wrote:

To build gtk, i did:
  ./configure CFLAGS="-g -O0" --enable-gtk-doc=yes  PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"

That won't work.  Should be:
PKG_CONFIG_PATH="/usr/local/lib/pkgconfig" ./configure CFLAGS="-g -O0"

or just do

export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"

and then do the configure.

Ok, i tried that, but i still get the same error after running:

  PKG_CONFIG_PATH="/usr/local/lib/pkgconfig" ./configure CFLAGS="-g -O0" --enable-gtk-doc=yes

I noticed that in gtk+/gtk/, there is this line of references
to things in /usr/lib:

# Libraries that this one depends upon.

dependency_libs=' -L/usr/local/lib /home/russell/AAProjs/GNU/gtk+/gdk/ -L/usr/X11R6/lib -lXinerama -lXext /usr/lib// /usr/lib/ /usr/lib/ -lz -lfontconfig /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /home/russell/AAProjs/GNU/gtk+/gdk-pixbuf/ -lXcursor /usr/X11R6/lib/ -lX11 /usr/local/lib/ /usr/local/lib/ /usr/local/lib/ /usr/local/lib/ /usr/local/lib/ /usr/local/lib/ -ldl /usr/local/lib/ -lm '

It contains: /usr/lib/
I haven't been able to determine why it happens.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]