Re: nameless instances of objects



*** WIDGETS DONT HAVE TO HAVE NAMES ***

But when I do:
widget = gtk_button_new(...);
I won't know the widget name.. are you telling me that I don't need to
give it a unique name? 

Yes.

That I can reuse the same name for each button I
create and add?

maybe, probably undefined behaviour in
gtk_rc_parse(); 
widgets can be named but dont _have_ to be:

http://developer.gnome.org/doc/API/2.0/gtk/GtkWidget.html#gtk-widget-set-name

exept for theeming; I dont see why you would _need_ your
widgets to have names. (in order to tell them apart ? 
see g_object_set_data())

Cheers,
                        -Tristan



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]