Glib compilation warnings.

Hi all,
I was wondering if anyone could tell me how to fix the following compilation warnings:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../intl -I../iproute2/include -I/usr/src/linux/include -I/usr/include -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/lib/glib/include -I/usr/X11R6/include -g -O2 -Wall -Wunused -c gtc_qdisc.c
In file included from /usr/include/resolv.h:66,
               from ../iproute2/include/utils.h:7,
               from gtc_qdisc.c:25:
/usr/include/sys/param.h:56: warning: `MIN' redefined
/usr/include/glib.h:137: warning: this is the location of the previous definition
/usr/include/sys/param.h:57: warning: `MAX' redefined


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]