Re: Gnumeric and SSconvert - Some cells in Lotus 1-2-3 have no value

I think the situation improved around version 1.12.19

The format is basically of historical interest only and improvements
happen only when patches are volunteered.


On Wed, Jan 6, 2016 at 12:29 PM, Ben Cundiff <ben getair us> wrote:
Hi Gnumeric mailing list,

I have about 4,000 spreadsheets in Lotus 1-2-3 format *.wk4. I would like to
automate converting them in to a format Excel 2013 can read.

I have gnumeric 1.12.9.

When I run ssconvert on sample file, I run:

ssconvert ./22250.BAK ./22250.xlsx –T ‘Gnumeric_Excelxlsx2’

This runs for a few seconds and I get a few hundred errrors that look like:

** (ssconvert:2912): WARNING **: Unknown record 0x17 of length 14

The number 2912  (behind ‘ssconvert:’) and the length varies depending on
the spreadsheet used for input.

When I open the spreadsheets in Gnumeric, spreadsheet contents are displayed
correctly except spreadsheet names are not retained, and certain random
cells are empty rather than having any value. I don’t get an error message
or NaN in the cells, they’re plain empty.

For instance, in a spreadsheet, cell B20 might have a value ‘$50,200.12’ in
the spreadsheet in WK4 format when opened in Lotus.

When opening in Gnumeric or after running ssconvert, most other cells
display correctly, but that cell is empty.

Do I have any flags I can feed ssconvert or Gnumeric when opening the source
spreadsheets to troubleshoot ~5% of cells with data failing to retain data?

Many thanks,



Ben Cundiff

Network Technician

AIR Technology Services

ben getair us

gnumeric-list mailing list
gnumeric-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]