Re: Problems with special characters - Solved!

When I read your mail I just remembered a Debian Weekly News article months 
ago: You have to insert in /etc/locale.gen all used character encodings and 
after inserting the line "en_US ISO-8859-1" and running "locale-gen" 
everything worked fine!

Thanks to all,

On Sunday 13 January 2002 11:12, Jon K Hellan wrote:
Christoph Fabianek <e9725236 stud4 tuwien ac at>(by way of Christoph 
Fabianek <e9725236 stud4 tuwien ac at>) writes:

I have the following problem with Gnumeric 1.0.1: Text containing special
characters (e.g., äöüß) is not displayed correctly in the cells i.e., it
only displays the characters till the first special character (example:
"zurückgeben" becomes "zur"), although the text is shown completely in
the "data entry area".

I have recently set up my computer from scratch (Debian/testing with
gnumeric from unstable) and perhaps something is missing, but no other
applications (including Gnome-Apps) show this behaviour. Does anyone know
a solution?

I had the same problem, when I was running Gnumeric in an invalid locale.
If you run it in an ISO-8859-1 locale, e.g. en_US, the strings render

I had my xterms configured with en_US, so things looked right when
starting Gnumeric from an xterm. But the desktop had locale "english",
which doesn't exist.

I fixed it by manually changing a line in ~/.gnome/gdm, under section
[session], from "lang=english" to "lang=en_US".

I believe the gdm's (gnome login window's) language selector maintains
this entry in the file, but there seemed to be no way to select a
valid English locale. A Debian packaging problem?

Hope this helps.

Jon Kåre

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]