problems using gnumeric 0.99

Dear People,

I was recently using gnumeric to make up grades for the class I was
teaching this fall. I'm using the version of gnumeric in Debian unstable

ii  gnumeric       0.99.0-1       A GNOME spreadsheet application

I would like to report the following problems I experienced (in no
particular order)


1) When cells are in a percentage format, and I try to print a sheet, the
percent sign is shown outside the cell in postscript conversion. This
shows up clearly in the preview. When printing, only part of the percent
sign is shown.

2) Exporting to a pdf file using the builtin facilities (Pdf writer) would
not work for me at all. What makes this strange is that in an older
version (0.64) worked for me with a very similar worksheet without any
problem. I get the following complaints.

** WARNING **:
Can't encode fonts with more than 1 page of glyphs for now.
Encoding only the first page of glyphs (256). The font in
question is :Helvetica, which has 316 glyphs.

I made no effort to switch fonts or anything else, but these are the
default fonts.

3) I also tried to export a sheet to html 4 format. Unfortunately, there
is no option to only export a single sheet, only the entire workbook. I
also noticed that hidden columns still showed up on the html output.


4) Once I hide a column, I cannot unhide it.

5) There is some feature that completes my typing in a cell based on what
I have typed in other cells. Ie I type elephant in cell A1 and then go to
cell A2, if I type el and pause, it completes the word to elephant. This
feature is presumably supposed to be helpful, but is more annoying than
helpful, and on occasion can be dangerous. When completing my student
grade sheets it was completing A's to A- based on the fact that I had
previously written A- etc. I am not sure how to turn this off. The Auto
Correct feature looks like it might have something to do with this, but
none of its advertised features sound like they should behave like I


6) None of the graphs/objects stuff works for me at all. This may be due
to missing packages, though. I think maybe I need to install this guppi
package. Is this right?


7) There appears to be no option to insert a spreadsheet in a particular
place. It is automatically created at the end and I have to move it where
I want.

8) I had a text file which I wanted to enter into a sheet in a
pre-existing workbook (call this Wbook A). I had to go through the
following steps.  a) Import the text file into a new workbook (Wbook B).
b) Select the region of cells in Wbook B, and paste them into the
appropriate sheet in Wbook A. It would be nice if there was a method to
import the text file directly into the sheet.

Furthermore, it would be nice if there was a way to manipulate sheets:
copy sheets from one workbook to another, create workbooks by splitting
off sheets from another workbook, without having to cut and paste cells.
There may be a way to do this currently, but I'm not aware of it.

I will send along other problems as I experience them. I can send along
the files I have used (suitably anonymised) on request, but most of the
problems I have experienced look like they are probably fairly
reproducible. I am sorry I have no fixes to suggest.

Let me conclude by congratulating the gnumeric developers. Gnumeric has
come a very long way in a short time. I remember not so long ago (99?)
when gnumeric was at version 0.2 or something, and it has become much more
functional since then. For the most part it is now an adequate substitute
for Excel.

If anyone wishes to respond to this, please cc me. I'm not on this list.

                                    Sincerely, Faheem Mitha.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]