Re: [GnomeMeeting-devel-list] [PRE-PATCH] private struct _GmTextChat



Hi,

I only have a few things to comment on :

- that kind of patch is, believe me, very dangerous. 

- I don't like 1 line functions, I don't think it makes much sense to
write 4 lines of code for a 1-line function.

- Functions to retrieve things should contain "get" in their names

- Things like :
gnomemeeting_text_chat_window (GmTextChat *chat)
{
  return chat->window;
}

do not make much sense I believe. Will you do a one line function for
each of the fields present in all structures?

- gnomemeeting_text_chat_window is misnamed too. See the rest of the API
to name it in a similar way.

Except this, I more or less like the idea.


Le dim 25/01/2004 à 21:07, PUYDT Julien a écrit :
> Hi,
> 
> this is not a patch yet, since it didn't get as much testing as I like,
> but I thought I would share it before going to bed, to get comments (the
> discussion on global/local variables was heated enough that I prefer
> being cautious).
> 
> Snark
-- 
 _      Damien Sandras
(o-     
//\     It-Optics s.a.
v_/_    GnomeMeeting: http://www.gnomemeeting.org/
        FOSDEM 2004:  http://www.fosdem.org
        H.323 phone:  callto:ils.seconix.com/dsandras seconix com




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]