Re: removal of duplicated code in gnome-vfs-uri



> This looks fine to commit. The only change in behaviour is the replacement 
> of g_return_val_if_fail() with normal comparisons in some edge cases (used 
> to be in make_full_uri_from_relative). g_return_val_if_fail() prints out a 
> warning if it fails and G_DISABLE_CHECKS is not defined. Maybe we should 
> add that back?

I finally looked at that, the only g_return_if_fail which will disappear
with this patch is 
g_return_val_if_fail (uri != NULL, NULL);
(the second one couldn't be triggered since base_uri couldn't be NULL)
and this case will trigger an assertion in gnome_vfs_uri_new because it
will be fed a NULL uri, so maybe that's ok to also remove that one ? 
This case would even disappear if we unify
gnome_vfs_uri_resolve_relative and gnome_vfs_uri_make_full_from_relative
behaviour when relative_reference is NULL.

Any thoughts on all that ? 

Christophe


Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]