Problems with "launch at startup" script

Hi all:

I'm using gnome shell since version 3.2. I also have a logitech mouse with zillions of buttons, and I have the problem that I hate to have the third button in the mouse wheel, so I've been using xmodmap in a startup script to put it in another button. The specific script is:


xmodmap -e "pointer = 1 13 3 4 5 6 7 8 9 10 11 12 2"

Until gnome shell 3.6 it worked like a charm, but starting with gnome shell 3.8 it started to fail in some boots, but in others it worked fine. Now, with gnome shell 3.10 it doesn't work at startup, and I must run it manually.

I checked the output of the script during launch (redirecting both stdout and stderr to a file) and the script runs fine (no errors), but the mouse buttons aren't changed. I also tried to remove it from the startup programs just in case the X server remembered the new button order, and each time I boot the script was changing it to the standard order, but no: the X server resets each time I reboot the computer.

I also tried to add a sleep in the script, just in case the problem was only if it was launched before gnome shell fully loaded, but also without luck.

So... what can I do?


Nos leemos
                         RASTER    (Linux user #228804)
raster rastersoft com    

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]