Palm m100, Evolution 1.0.7, and gnome-pilot 0.1.64

I am using a debian unstable system with Evolution 1.0.7 and gnome-pilot
0.1.64, pilot-link 0.10.99, and syncing to my palm m100.

I purchased my Palm m100 about a month ago, and unfortunately cannot
remember what versions of Evolution and gnome-pilot I was using at the
time. At that time, syncing with Evolution worked perfectly.

At this time, however, and with the versions listed above, I can get
everything but the datebook to sync. When I attempt to sync the datebook
-- either as a sync operation or copy from pilot -- after about the
fourth record, gpilotd crashes.

When I run gpilotd from a terminal, I notice the following:
 gpilotd-Message: gnome-pilot 0.1.64 starting...
 gpilotd-Message: compiled for pilot-link version 0.9.5

which I find odd, as I've got pilot-link 0.10.99...

The next thing I notice is when the datebook tries to sync:
 cal-util-CRITICAL **: file cal-component.c: line 3597
 (cal_component_set_summary): assertion `summary->value != NULL' failed.
This happens for three entries, and then gpilotd crashes.

The crash I get is:
 Application "gpilotd" (process 4363) has crashed due to a fatal error.
 (Segmentation fault)

I've tried syncing with other programs -- jpilot works, as does the Palm
Desktop software on my Windows partition, and pilot-xfer will always
backup/sync/install files. I want to use Evolution, however -- I
occasionally have need to export or send appointments or contact info as
vcal or vcard items.

Any ideas?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]