Re: Corba-izing gnome-pilot



On Mon, 23 Nov 1998, deity@dbc.dk wrote:

> On Fri, 20 Nov 1998, Manish Vachharajani wrote:
> 
> > > CORBA_ORB to conduit_get_gpilot_conduit.  Each conduit should not
> > > create it's own orb, but use the pilot's.  In addition, gpilotd should
> > I am not too familiar with how ORBit works, but if we don't pass this
> > parameter, will the conduit just create its own data structures to
> 
> A CORBA_ORB structure is the structure used to all orb interaction,
> included is requesting a object of type blah.
> 
> Giving the CORBA_ORB to the conduit will spare the extra memory and
> overhead of an extra CORBA_ORB structure, it may, however, never share the
> exception structure.
> 
> I think giving the orb to the conduit it ok. In the orb part, I currently
> have the CORBA_ORB as a global variable. If i move it into
> GPilotd_Orb_Context, manager.cc can access the ORB_Context and get the
> CORBA_ORB. We can then pass it along in GPilotDBInfo, with the
> pilot_socket etc. Does that sound reasonable ?

This sounds pretty reasonable, but we should do it as follows, so as not
to require conduits writers to have ORBit devel around.  Add a function to
conduit_support.c that returns the CORBA_ORB pointer from the
dbi->manager_data structure as a void *.  In the gpilot-conduit.h file we
add a macro that just calls the the fucntion and casts the return value to
CORBA_ORB, and we add a prototype for the void * returning function as
well. This will avoid the need for conduit writers to have the orbit
include stuff around unless they use CORBA.  When adding the CORBA_ORB
field though, we should change the name of the stored structure from
GPilotSyncStamp to GPilotConduitSupportInfo or something similar and just
have a static GPilotSyncStamp entry in this structure.

This way, as long as no one invokes the gpilot_get_corba_orb macro they
don't have to worry about, CORBA_ORB undefined errors.  We should also add
comments about why the conduit_support function returns void * instead of
the CORBA_ORB data type.
 
> Ad. regstrating the gpilotd. Currently I put the IOR in
> .gnome/CORBA-servers like the panel does, is this the registration you
> mean, or do you mean something from libgnorba ? (goad_server_register
> looks like a prospect).
> 
> I won't use gnome_CORBA_init since it also initializes gtk+.
> 
> eskil
> ---
> 

Manish Vachharajani               Some Haiku: A crash reduces
<mvachhar@vger.rutgers.edu>                   your expensive computer
                                              to a simple stone - Unknown



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]