[gnome-mud] Alias on 0.11.2

Hello everybody,

I am new here, but I've been an affectionate gnome-mud user for two years by now.
I apologize for my not perfect English and for my lack of a technical language, but I am Italian and although I am a mud manageress, I am not a programmer.

I am writing here because I have a problem with the setting of aliases in the 0.11.2 version, currently running on an Ubuntu 9.04, and that I hadn't with the older version 0.10.7 compiled on Gentoo.
I tried a Google search and I also tried to find something in this mailing list archive to solve my problem, but I could not succeed. I hope some of you could help me.

When in the older version (0.10.7) I set an alias and a replacement, the mud automatically runs the command I put in the replacement and allows me to add a further specification for that command during the game. I could, for instance, choose to type "fireball" to make a character execute the command "cast fireball" and specify the name of the victim in game.
A simple "fireball John" works perfectly (the mud code runs a "cast fireball John").

With the new version (0.11.2) the layout has changed. If I put in the regex my short name for the spell ("fireball") and in the action list the full command ("cast fireball") the character only casts the spell on himself and I cannot add the target during the game.
If I type "fireball John" it results in an unknown command.

I don't know if it's just me that can't make gnome-mud work properly or there's something wrong.
I may add that our mud is based on a Merc2 code and that the new triggers features run perfectly and are very useful.

Thank you in advance for your kind attention and for all the work you've done until now.

-Eli "Morlach"-

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]